Home Engineering Room

Facebook 7.2.0 problems

edited June 2019 in Engineering Room
Since the new build - maybe a day or so before - I cannot get my game to load on facebook without an annoying prompt to link to mobile version. That screen offers two buttons: "new game" and "play game," however "play game" leads not anywhere.
Refreshing the site sometimes works, sometimes leads back to this roadblock.
Also the stability has not improved for me, instead more ship battles run into memory problems than ever before.

Is there a simple fix for the first problem I'm just not seeing?
«1

Comments

  • ShanShan admin
    Could you please check that your browser accepts 3rd party cookies and see if that helps with the screen showing "new game" "play game"?

    Regarding the issues during ship battles, is that for Battle Arena only or any ship battles.
    What are the specs of your computer?
  • I encountered the ship battle issue during Arena battles, almost exclusively. That has happened before, but very seldom, since the upgrade I've had it crop up at two or three times per arena day, which uses up the arena attempt without a chance at winning and the ship battle counter not moving.

    I'm using a MacBook Pro from early 2015, but while this is ancient tech I don't normally run into any such issues.

    I'll try the cookie setting, and if any issues persist I'll open a ticket.
    Thanks for the quick answer.
  • ShanShan admin
    What browser are you using and which version?
    Does this happen in all divisions?
    What ships are you using when it happens?
    We are trying to look into this so any details might help :) Thank you!
  • Hi! I have the same problem. I play on Mozilla Firefox, Version Firefox Quantum 67.0.4 (because on Google Chrome the app through Facebook will not even load) and for the past couple of days I get the same prompt to connect to the mobile version (refreshing helps, but it takes a couple of takes) and the battle arena "out of memory" message appears exclusively on the Admiral division. I too play on a Mac Book Pro, with Mojave. I hope this might shed some light into the problem... Thanks!
  • ShanShan admin
    Hi! I have the same problem. I play on Mozilla Firefox, Version Firefox Quantum 67.0.4 (because on Google Chrome the app through Facebook will not even load) and for the past couple of days I get the same prompt to connect to the mobile version (refreshing helps, but it takes a couple of takes) and the battle arena "out of memory" message appears exclusively on the Admiral division. I too play on a Mac Book Pro, with Mojave. I hope this might shed some light into the problem... Thanks!

    Hi!
    I am sorry about this.
    We are looking into the "out of memory" issue.

    Regarding the prompt to connect to the mobile version, could you please check that your browser allows 3rd party cookies? Thank you!
  • DeanWinsDeanWins ✭✭✭✭
    Just wanted to include the actual error message, in case it helps narrow down the problem.

    gmvbllqvs3ob.png
  • ShanShan admin
    OK I have renamed this thread for clarity.

    Regarding the "webgl out of memory" error, when reporting it please provide additional details such as:

    - hardware: how much memory does your computer have, which operating system, antivirus?
    - browser used?
    - when does it happen?
    - if it is mostly in Battle Arena did you notice if it happens in a specific division, and/or with a specific ship?

    As much as I hate asking this, could you try clearing your browser's cache and see if it helps?

    Currently we have little to go on and any details could help especially since it seems the % of players affected is small.

    Thank you so much!
  • DeanWinsDeanWins ✭✭✭✭
    edited June 2019
    My computer is a dinosaur, however I don't think that is the issue, since it has gotten progressively worse with each update. I'm not a tech expert, but based on what the error message says it sounds more like an error on the programming side, maybe too much memory for the application.

    The error, happens pretty much exclusively on Arena battles, and bit less on skrimishes, specifically admiral division.

    It also happens in the new or newer daily missions and campaign menu, and it never happened in the old one.

    and rarely but it has happened in the Starbase menu.

    I also think you guys might underestimate the impact of the error, since I think its been said a small % of the player base even uses the forums, so many players may just give up on the game, and never give feedback based on these errors.

    Also, I do play on mobile as well, when I am away from the dino desktop, and Ive never had these errors on that platform ever, so maybe some kind of conflict with the actual browsers.

    Hope that helps, and maybe some of the others can give more detail.

    Oh and if it hasn't been said, we do appreciate your efforts Shan as always, on this and all the issues you help with;)
  • Having the 'Out of Memory' problem on all divisions of the arena battles, and on the 'Campaigns' page of daily missions. Also sometimes the gauntlet randomly freezes after clicking on 'Engage', it just gets stuck there and I have to reload.
    Using W7, 12gb ram, Malewarebytes, Chrome.
  • DeanWinsDeanWins ✭✭✭✭
    edited June 2019
    yap still happening, dailies could be annoying before, now they are just painful, especially since when you get an out of memory error during an arena battle it doesn't even count as a go, but still takes it away, not sure how that is possible

    Not to be rude, but someone remind me again the point of this update? other than making the game more unstable, I have yet to see one advantage to it besides the load screen being different.
  • Glad I am not the only one who is having problems since this update, my game constantly crashes for no reason, claiming the same memory issue, and when I do load the game I have to do it several times, its really fustrating
  • Hi, I am also dealing with this issue. The Out of Memory notice appears during arena battles, usually at the end so it still registers, and in no particular class. It appears from time to time when trying to load a menu such as opening the Starbase, opening the Time Portal and when travelling to a new mission. It also occurs during Gauntlet. I routinely have to reload the game several times during a session due to the frequency of the message. On the positive side the game is loading very fast. I have had shocking internet speeds where it has taken upwards of 10 minutes at times to load. That has corrected itself and now it will load in under a minute. That is great news.

    I also experience the screen when trying to load of the option of New Game, or Play Game. It is just a matter of reloading a few times for the game to start up. The other issue that has arisen is the Replay button occasionally disappears in both Away Missions or Space battles. You then need to go through the process of reselecting the mission and crew. This is very frustrating especially in the midst of an event. Sometimes it is only gone in away missions. Often a reload makes the button come back and I can play as normal for a day or two. Today it came and went.

    Otherwise the speed of the game is great, images load quickly and the game loads quickly. I am hoping there is a solution to this current issue. I play via the Facebook platform, usually on Firefox. I have changed settings to accept 3rd part cookies. The computer is an iMac and only two years old and is on the latest operating system. Thanks for your time, and providing a great game. I appreciate the effort in keeping it running smoothly.
  • Shan, thank you for all your efforts.
    Additional issues:
    – When the game runs out of memory forcing a reload, it resets the sound to an annoying 100% instead of keeping the 5% I use. So far this has been consistent.
    – Earlier today it also randomly set the language to German. Twice, today. While it is true that I am running it via facebook from Germany, I use English both as the Facebook preferred language and in the game. (I have, in the past, used German in the game, but switched for ease of communication with my fleet mates)
    – the monthly card, and anything offered for real life currency was "locked" earlier. Seems to work at the moment though.
  • Emperor Borg DroneEmperor Borg Drone ✭✭✭✭✭
    When I log in through Facebook, I don't usually do it on a browser but on their Gameroom app and on Gameroom I've had the "out of memory" issue for much longer, especially when opening the chat or doing arena battles. I mostly play on my phone and almost only use Gameroom for purchases, so I never cared too much about it. I tried to play on Gameroom today, to see if it happens more often than before and it doesn't seem that way (it happened once or twice so far, while I was trying to write in the chat and at the end of an arena battle). I think that it happens more if I'm doing other stuff at the same time or if I have lots of tabs open in a browser, but it tends to happen regardless, even if Gameroom is the only open window.
    Just out of curiosity, I tried to start the game directly on Facebook (browser is Firefox) and I did 5 arena battles. The "out of memory" error only showed up on the last one.

    My notebook is old and cheap, which is another reason why I never cared too much about this issue. Ram is 4 GB and the antivirus is Norton.
  • <TGE> Darxide<TGE> Darxide ✭✭✭
    edited June 2019
    Facebook version:

    After about 5 seconds I get this:

    go6yc730ljeb.png

    I also don't know why the game interface is setup like it's running on a phone. All the hud elements are huge and cramped. It looks a thousand times better on my iPad.

    Also also, Why does Earth look like a haze? The FB version also seem to run lower resolution textures than my iPad. Why? It's like the Steam version. It runs at 60fps, but it's chunky as hell. I'd prefer the slower response, but better visuals of my iPad any day of the week.

    zxp9d6dae9jo.png


    EDIT:
    An example of what I mean by the FB and Steam versions using a squished phone interface, here is a comparison:

    Facebook version (at fullscreen):
    dq5eckaedq9d.png

    Steam at fullscreen: (notice the different "On Voyage" icon and "Default Sort" font size)
    w83b591advfu.png

    On my ancient Android phone: (forgive the blue light filter)
    rkb0tv1kld5g.png

    All pretty much the same. Now, for my iPad Air:
    znabvbqjmrvc.png


    Look at how much more spacious the iPad version is. Look at how many more crew you can view at once. It isn't just this screen, it's every screen. I feel claustrophobic whenever I'm on anything other than my iPad. Frankly, every desktop, tablet, and large phone versions should be like this. Only smaller phones should look like the other examples.
  • Hello, I'm having the same issue out of memory.
    For me it doessent matter what i'm doing in the game but it apears mostly during combat.
    It doessent seem to matter what kind of ship you use and got worse after the lasted update of the game.
    i'm playing thrue facebook gameroom and are using opera but also tryd chrome and firefox doessent matter same issue there.


    My system is operating with windows 10 64 bit

    Operating System
    Windows 10 Pro 64-bit
    CPU
    Intel Core i7 950 @ 3.07GHz
    Bloomfield 45nm Technology
    RAM
    12,0GB Triple-Channel DDR3 @ 532MHz (7-7-7-18)
    Motherboard
    MSI Big Bang-XPower (MS-7666) (CPU1)
    Graphics
    AL2016W ([email protected])
    8192MB ATI Radeon RX 570 Series (ASRock)
    Storage
    447GB Patriot Burst ATA Device (SATA (SSD))
    149GB Western Digital WDC WD1600AAJS-22PSA0 ATA Device (SATA )
    465GB SAMSUNG HD503HI ATA Device (SATA )

    Furthermore i use windows defender and super anti spyware.

    Hope this wil help a bit resolving the issue
    Greetings ,
    wouter.


    P.s no issues with 3 party cookies
  • DeanWinsDeanWins ✭✭✭✭
    so are we getting any answers on this anytime soon, or facebook users just out of luck? if so Ill be more than happy to shop for another game, cause it is kind of ridiculous
  • It's become almost impossible to complete the daily missions now, and it constantly crashes on the galaxy map.
  • Is there any chance that you will at least remove the screen prompting to link to my mobile that does not allow me to get into the game at all without a random number of reloads, that likely is higher than three?
  • edited July 2019
    apparently they dont care that much...

    If they did they would realize the game is virtually unplayable on facebook.
  • edited July 2019
    This is what the INTERNET says about the problem, if any programmers know what it means ?

    How do I increase my WebGL memory?
    What are the best practices to reduce memory usage ?

    Reduce the size of the Unity Heap: Keep the 'WebGL Memory size' as small as possible.
    Reduce your code size: Enable Strip Engine Code. Disable Exceptions. Try to avoid usage of 3rd party plugins.
    Reduce your Data size: Use Asset Bundles. Use Crunch texture compression.

    Either way, it indicates its on the programmers side, not the user side, so nothing the players can do about it.
  • edited July 2019
    "An error occurred running the Unity content on this page. See your browser JavaScript console for more info. The error was:
    uncaught exception: abort(151) at jsStackTrace (Timelines.asm.framework.unityweb:2:27460)
    stackTrace (Timelines.asm.framework.unityweb:2:27631)
    abort (Timelines.asm.framework.unityweb:4:40368)
    QhF (Timelines.asm.code.unityweb:74:1)
    rJm (Timelines.asm.code.unityweb:19:1)
    tJm (Timelines.asm.code.unityweb:19:1)
    sJm (Timelines.asm.code.unityweb:19:1)
    ERn (Timelines.asm.code.unityweb:16:1)
    CRn (Timelines.asm.code.unityweb:16:1)
    zFu (Timelines.asm.code.unityweb:7:1)
    IMB (Timelines.asm.code.unityweb:8:1)
    $Nk (Timelines.asm.code.unityweb:4:1)
    p9E (Timelines.asm.code.unityweb:74:1)
    invoke_iiiii (Timelines.asm.framework.unityweb:2:343185)
    fsE (Timelines.asm.code.unityweb:63:1)
    LCE (Timelines.asm.code.unityweb:63:1)
    fpa (Timelines.asm.code.unityweb:21:1)
    $oa (Timelines.asm.code.unityweb:21:1)
    snb (Timelines.asm.code.unityweb:64:1)
    pnb (Timelines.asm.code.unityweb:64:1)
    pnb (Timelines.asm.code.unityweb:64:1)
    xnb (Timelines.asm.code.unityweb:64:1)
    cAb (Timelines.asm.code.unityweb:61:1)
    Gnc (Timelines.asm.code.unityweb:40:1)
    Zic (Timelines.asm.code.unityweb:28:1)
    Nic (Timelines.asm.code.unityweb:28:1)
    YbF (Timelines.asm.code.unityweb:74:1)
    browserIterationFunc (Timelines.asm.framework.unityweb:2:210331)
    runIter (Timelines.asm.framework.unityweb:2:192385)
    Browser_mainLoop_runner (Timelines.asm.framework.unityweb:2:211878)

    If this abort() is unexpected, build with -s ASSERTIONS=1 which can give more information."


    ––––––––––––––––––––––––––––––––––––––

    This is the lastest error message, after the game crashed, deleting another arena battle attempt (as in: after reducing the ticket number, bugging out during the battle, thus making a win impossible and to add insult to injury not even counting the battle toward daily ship battles and daily arena battles). In combination with the game randomly not loading to to the "link your account" screen that is impassable, as the buttons do nothing, that has cost me at least one day's completion and accordingly my progress in the campaign.

    Frankly, the silence on the issue is deafening.
  • It is a holiday weekend. dont expect much of an answer until at least Monday.
  • I know. And in the original version of my last comment I actually mentioned that I understand that it is a holiday week in the US and do think that it is a kind of excuse. I decided to strike that, because the issue is become worse with the update, and this thread was opened significantly before July 4th.
    That there has been no "we are aware of the issue and try to remedy it. We cannot pull the link screen because (insert whatever possible reason there could be), but we are working to find a solution" message is what I meant with "deafening silence." :neutral:
  • Dirk GundersonDirk Gunderson ✭✭✭✭✭
    The only positive sign I see is that 7.2.0 hasn’t been pushed to other devices yet - usually, iOS and Android get the update within a week or so, with forced acceptance following maybe another week after that. We’re about two weeks in and haven’t heard a peep about the upgrade going out for everyone else. With any luck, 7.2.1 is coming for everyone real soon and those who have suffered through the 7.2.0 bugs on Facebook will get something more than some restored arena tokens by way of apology.
  • edited July 2019
    My guess is it is mainly a Facebook issue, because it involves using browsers, which you dont use for phone and streaming.

    This issue wouldn't be so bad as if some have already pointed out, that it didnt completely screw up your arena goes, and thus make you unable to complete dailies for the campaign, which people have actually paid money to unlock.

    If they can't resolve this issue, or are going to take their time about it, they might want to think about yanking arena goes from the campaign list of chores.

    I don't know what percent of players uses facebook to play, but seeing as timelines advertises on Facebook, it would suggest they want players from that platform, and would make sense they might want to addresses the problem or at least take it seriously.

    As Aegon pointed out, this issue started before the holiday weekend.
  • ShanShan admin
    I do not have any update regarding the webgl error messages, I am sorry.
    Please submit a ticket so we can track the number of players affected and potentially find a commonality.

    We are also looking into it on our end but no luck so far.
  • Submitted a ticket a few days ago. Hopefully this, or at least the "link you account" start screen – that should more properly read "thou shalt not pass" ;) – is removed by then. It would be highly frustrating to have a skirmish event with the current problems, given that these had me fall widely off the mark of what I had planned for the Sting event.
    No Wrathful Kirk for me, I guess.

    Thank you Shan (and to the whole customer support team) for your help.
  • ShanShan admin
    Facebook has been rolled back to the previous version, 7.1.0, while we investigate what was causing the issues you have been reporting. Thank you for your patience, and again, my apologies for the inconvenience/frustration these issues have caused.
  • Wow that was cool of you guys to roll it back, kinda shocked actually. Hopefully you guys can figure out what happened/
This discussion has been closed.