[Resolved] Can't purchase anything through steam

edited October 9 in Engineering Room
Whenever I try to buy a pack/campaign/Monthly card through steam the hailing starfleet loading circle just keeps spinning and does nothing. The only way I can even get out of it is to hard close the game. I know I can use other platforms to buy stuff but I would rather do it through steam. Thanks for any help you can offer.

Comments

  • MuffanMuffan ✭✭
    Same here.
  • ShanShan admin
    Steam overlay is enabled?
  • edited October 8
    Just checked it, yes it's enabled.

  • ShanShan admin
    At this time I see no other report of this, no tickets.
    I tried on my end with the LTO and saw the purchase dialog just fine.

    Where does this happen for you specifically?
  • On any of the purchases for dollars, and it's not just me my girlfriend can't buy through steam either. We can do it through the Microsoft app just fine though.
  • Ok I got it working on my girlfriends pc by disabling and enabling the steam overlay. But it didn't work for mine. I have uninstalled and reinstalled STT. I do not want to do that with steam because I have about 20 games on it that would all have to be installed again. It makes zero sense to me.
  • edited October 9
    Ok I got it working, your question got me digging and I found the solution. Not only do you have to make sure that the ingame overlay is checked in the Steam settings, but you also have to make sure it is enabled for STT also. I did this by opening Library, right-click on Star Trek Timelines and open Properties. Check the “Enable the Steam Overlay while in-game” box and save changes. Restart Steam. All good now Shan, thanks for the help.
  • ShanShan admin
    Ok I got it working, your question got me digging and I found the solution. Not only do you have to make sure that the ingame overlay is checked in the Steam settings, but you also have to make sure it is enabled for STT also. I did this by opening Library, right-click on Star Trek Timelines and open Properties. Check the “Enable the Steam Overlay while in-game” box and save changes. Restart Steam. All good now Shan, thanks for the help.

    Aha! Thank you for reporting back, I am glad it got resolved.
    And I learned something as I was not aware the overlay could be disabled per game though it does makes sense :)
Sign In or Register to comment.