Home Engineering Room

Bug with missions and character leveling.

So since i started the game back in the day i had multiple missions and ship battles passed, however something with the missions is bugged. Yesterday i got another fully passed mission which was needed to get my character to the next level and everything seemed to be fine. However when i got to the character screen and i wanted to get a few things for my character to level him up the mission(s) are missing from the Obtain screen. This is not a new bug, but an old one that has been happening to me for a long time. Is there a solution?

Comments

  • Banjo1012Banjo1012 ✭✭✭✭✭
    Only thing I can really say is look at the rewards before you run the mission. I’ve fallen victim to this many times myself, so now I always check to make sure what I need is there before I run it
  • I don't think you are talking about the same thing, Banjo :)

    So if I understand correctly, sometimes you go to a character, check the equipment they need and when going in the GET menu, you see no missions at all?

    I have not heard of that one before.
    Does it happen every time or only after certain steps are taken?
    When you restart the game, does it solve the issue.

    On which platform are you playing?
  • edited February 27
    Shan yes it happens every time. I'm on steam, but its also on Android as well. So here is the thing, yesterday i had to level up a character i think it was Arjin i had to level him up by using Science experiment. Here are the pictures:
    https://i.imgur.com/6uuQRwZ.jpg
    https://i.imgur.com/dSDTXfh.jpg
    https://i.imgur.com/3ReOTvg.jpg

    As you can see i have the mission and yet in the menu for the character in which i have to obtain there is only a shuttle mission.
  • Shan yes it happens every time. I'm on steam, but its also on Android as well. So here is the thing, yesterday i had to level up a character i think it was Arjin i had to level him up by using Science experiment. Here are the pictures:
    https://i.imgur.com/6uuQRwZ.jpg
    https://i.imgur.com/dSDTXfh.jpg
    https://i.imgur.com/3ReOTvg.jpg

    As you can see i have the mission and yet in the menu for the character in which i have to obtain there is only a shuttle mission.

    That was a rare reward, meaning you can only claim it once.
  • Data1001Data1001 ✭✭✭✭✭
    edited February 28
    Shan yes it happens every time. I'm on steam, but its also on Android as well. So here is the thing, yesterday i had to level up a character i think it was Arjin i had to level him up by using Science experiment. Here are the pictures:
    rqfdbovfhkpt.jpg
    0s6pnsvinr93.jpg
    mcdfnhnb0sgj.jpg

    As you can see i have the mission and yet in the menu for the character in which i have to obtain there is only a shuttle mission.

    That was a rare reward, meaning you can only claim it once.

    are_dub is correct. And I can see by the images you shared that you've already claimed it from that mission as a rare reward.

    As you can see in this screenshot taken from the wiki page for the Science Experiment, the 2* (Uncommon) version is only available as a rare reward (meaning, only available once) from certain missions, and 2 of the weekly Cadet Challenges. Other than that, the only places you can get it is Augment shuttles or the Augment Faction center. (Though it of course could potentially drop in Voyages, Gauntlet, or from other non-farming sources, but that wouldn't happen with any regularity.)

    fotam71kfss5.png


    (images in original post downloaded from external source, cropped and re-uploaded)


    Could you please continue the petty bickering? I find it most intriguing.
    ~ Data, ST:TNG "Haven"
  • Then i guess this can be considered resolved!
  • Aha!
    So Banjo was indeed correct.
    I know this is a real annoyance and I hope we will find a solution for it.
  • Banjo1012Banjo1012 ✭✭✭✭✭
    Shan wrote: »
    Aha!
    So Banjo was indeed correct.
    I know this is a real annoyance and I hope we will find a solution for it.

    Props from Shan! Thank you my friend!

  • PhantumPhantum ✭✭✭
    edited March 1
    This is a known issue that has been going on for as long as I have played the game. There are other forms of this where the game confuses missions and you end up running a mission that has zero or a very low chance for drops. There are about 2 dozen items I know of where this happens. You can read more about it in the thread here
    https://forum.disruptorbeam.com/stt/discussion/12937/item-dropped-by-same-mission-with-different-difficulties-do-not-show-least-difficult-option#latest
    And it is also mentioned here
    https://startrektimelines.zendesk.com/hc/en-us/articles/115001744388-Known-Issues-and-Clarifications

    The reason it happens is that data transfer between the client (your end) and server (DB end) is interupted or fails. The game does not check that the data is syncronised correctly. This or something similar is responsible for various other issues such when the previous battle ability is frozen on screen in a ship battle. You can also check it using the API such as here
    https://stt.disruptorbeam.com/player,
    or do your own program to see the game interface .

    You just need to remember the 2 dozen items involved and check the missions. You can fix it any time by restarting the game which forces synchronization of data with the server. It has been known for well over a year in which time there have been several game updates, so I think it is not going to get fixed with current priorities . If you forget and waste chronitons on one of the missions then take a screenshot and send a support ticket and they will refund you all the chronitons and some compensation.

    I hope this helps. It was really frustrating to me to find out how many chronitons I had wasted early on in the game when they were really needed.
  • CuttysarkCuttysark ✭✭✭
    edited March 1
    @Phantum

    are_dub is correct on his analysis of this matter. This particular case is not a 'lag time' or updating matter. Other issues may exist but I've never seen them manifest themselves in any of my play. I hope you can resolve the issues you are experiencing. :):)
    Remember: it's just a game, not a matter of life and death!

    My Captain Idol's
    My DataCore page
    My Spreadsheet
  • PhantumPhantum ✭✭✭
    Cuttysark wrote: »
    @Phantum

    are_dub is correct on his analysis of this matter. This particular case is not a 'lag time' or updating matter. Other issues may exist but I've never seen them manifest themselves in any of my play. I hope you can resolve the issues you are experiencing. :):)

    Thanks for the correction there.

    You are 100% right about this particular case, I miss read it. It just came up on my alert for posts relating to costs of items on missions. This was similar to another known issue (shown on my link) where the rare reward starts showing up as a regular reward (with 5 circles) after you have claimed it as a rare reward. Of course you never get anything because it is only a rare reward.

    That is also a fair comment that you may not have noticed the issue with the missions as reported, but it would not show up unless you were tracking the frequency of the drops you get. Then you need to check it with the API to see that the info the local game has is not the same as that on the server. There are several missions where the chron cost is substantially different.

    If the instance I reported was due to updating data, then it would also not be observed by people with good internet conections and short traceroute to the server, such as in the US. It happens to me in Finland, but also much worse when on holiday in Australia with the longer internet routes.

    Sorry that I completely missread the issue in this post.
Sign In or Register to comment.