Home Engineering Room

Elusive treasure pack Single pull with no crew reward

Hi all,

I opened one elusive treasure single pull and received nothing. I'd like my dil back please.

I am using android if that matters. I sadly have no screen but I defo got nothing.

Edit: I already sent a ticket to support.

Comments

  • HerbertHerbert ✭✭✭
    Same issue; ticket sent.
  • Had a fleetmate report the same issue.
  • Same issue too, ticket submitted
  • ShanShan admin
    Looking into it!
  • Thanks Shan :-)
  • starfoxstarfox ✭✭
    i just paid for the two 10x packs but the thing to redeem them in the portal is gone
  • I bought the pack and cannot see the Elusive Treasures pack in the portal.

    Ticket sent.
  • starfox wrote: »
    i just paid for the two 10x packs but the thing to redeem them in the portal is gone

    Same issue here, opened ticket with helpdesk
  • Frank?Frank? ✭✭✭✭✭
    They pulled the pack to fix the error with the 650 DIL pulls folks - no need for tickets. Standby.
  • ShanShan admin
    All right!
    So the issue with the 1x pack has been fixed.
    Both packs are back where they should be.

    For players who purchased the 1x pack while it was borked, we will be fixing it automatically for the players affected.

    I will update this thread once it is done.
  • thank you
  • Thanks again Shan, also love the use of "borked" 😁
  • ShanShan admin
    Some words just have to be used :wink:
  • ShanShan admin
    OK
    Those of you affected should now be able to claim your 1x pack.
    You might need to close/reopen the time portal.
Sign In or Register to comment.