Home Starfleet Communications

v7.4.2. required for iOS/Android starting tomorrow - Clarification

ShanShan admin
edited March 18 in Starfleet Communications
If you have not already updated to 7.4.2. please do so as soon as you can.
We will force upgrade tomorrow, March 19 some time before 10am ET (14:00 UTC)
Sign In or Register to comment.