Home Engineering Room

Stuck Voyage

This discussion was created from comments split from: Ads Issues/concerns? Post here!.

Comments

  • edited July 17
    Hi everyone.

    I am playing on an Android phone and I am currently on a long voyage (2 days 22 hours 25 minutes) and trying to revive my Voyage with dilithium. I have enough dilithium, but when I am trying to use it a pop-up appears mentioning an "unspecified error" and suggesting to turn to the customer support.

    I have not contacted support yet because I just revived my Voyage 2 hours before this problem occurred and everything went smoothly then. So I am suspecting this problem can be temporary.

    I have two questions for the community though:

    1. Has anyone tried to revive a Voyage (specifically with dilithium) or tried to use dilithium in any other way since 16:00 New York Time July 17th?

    2. I am only one Dilemma away from completing all 36 Dilemmas. I have found out that there is (or was) a bug in the game that prevents recalling a Voyage after completing the 36th Dilemma. Does anybody know has it been fixed yet?

    Thank You.
  • Regarding my previous comment.
    I contacted customer support, they recalled my Voyage and I received all the rewards gathered during the Voyage so far.
    Problem solved.
Sign In or Register to comment.