Home Engineering Room

Ads no longer play - no rewards

Hi,

Since the last update ads no longer play when I click on the Orange button. An ad will show but not play.

Android.

Thanks.

Comments

  • Is it still occurring and could you provide specifics about your device and the version of android on it. Thank you!
  • Lenovo P2.

    Latest version of Android whatever that may be.

    To be honest, I have plenty of gear and I figure I can do without the ads. Hey-ho. Down to three logins a day now to simply go through the motions - Slowly being weaned - so thank you! :)
  • Is it something to do with the software that was removed as part of the last update?

    Or perhaps the plethora of 'offers' you now bombard us with every day? (Overkill btw)

    I am missing the ads today because it's boost packs day, but like I implied above, STT will miss the income more - it's not really my place to tell you how to earn more money.
  • What was removed had nothing to do with ads, so no it should not be the issue.
    This is occurring for every ad?
    You do not have an ad blocker on your device or something similar that would prevent ads to play?

    So far I am not seeing other reports of this happening to other players.
  • I think alot of ppl have become so used to it they ignore it now.
    I have a kindle fire 7, 9th gen running os 7.3.1.7. Purchased this device for STT only i dont do anything else with it. Current updated STT version 7.6.3, with over 7gb space avail. It refuses to play adds or crashes on adds more often than not. Im lucky if i can get 1 add a day to go right. It crashes or freezes frequently throughout collecting dailies, fleet rewards, and accolades, even while training, space battles, even just switching from a voyage in galaxy map back to entry screen. It is very clear that it will freeze or crash if i am in game more than 15 min consecutive. My best work around has ben to just restart when it becomes laggy after about 15 min. But certainly my work around should not be the normal.
    I have multiple ios devices always currently updated. various versions if ipad vs iphone.
    All are currently updated with latest STT avail prior to forced upgrade.
    They have all been doing the same thing on adds. “Sorry there was a problem” on a black screen appears often. Or the orange button is there but wont work as described above. If i continue to hit the add button when it doesnt want to respond it crashes me out of the game on any device i am using at the time.
  • Shan wrote: »
    So far I am not seeing other reports of this happening to other players.

    Except for the new thread that was created to report this?
Sign In or Register to comment.