Home Engineering Room

USS Excelsior Texture Error

There seems to be something weird above the Excelsior's deflector, I presume this is a texture error. Can it be fixed?0t54n3st0tah.png
in4c3av1bw1n.png

Comments

  • /SSR/ AHSOG/SSR/ AHSOG ✭✭✭
    The 2 colored areas under the Secondary Hull are missing, possible it's related to the above (hull texture is rotated 180 degrees?) The middle bit it likely supposed to be in the deflector recess.
  • /SSR/ AHSOG/SSR/ AHSOG ✭✭✭
    And (aside from the Voyager episode "Flashback") the original Excelsior's nacelles never glowed Blue, that was a DS9-era thing. In all the TOS Movies with Excelsior, her nacelles were dark, even at warp.
  • RW_EagleRW_Eagle ✭✭
    Don't know if they will change it, just like the 1701-A outboard nacelles are blue in game, when they shouldn't be.
  • /SSR/ AHSOG/SSR/ AHSOG ✭✭✭
    And the 1701-A has Red in the nacelles at the front in STT, which is wrong, as it never had Bussards like the 24th Century ships. Real simple fixes they could make to improve things... Sigh.
  • /SSR/ AHSOG/SSR/ AHSOG ✭✭✭
    Star Trek Online is gradually doing a massive ship update program, vastly improving the original assets in the game. A shame that STT can't do something similar. The 1701-D in STT is atrocious.
  • Shy KhanShy Khan ✭✭✭✭✭
    For some reason the Timelines crew seem adamant about making TOS-Movie-era ships' nacelles blue. They did the same thing to the 1701 refit. A shame, because those ships are striking with the matte black nacelles.

    I wonder if they got that blue from the Diamond Select Toy model. On mine, the nacelles light up blue.
    Come join the Steeler Nation Fleet!
  • ShanShan admin
    There seems to be something weird above the Excelsior's deflector, I presume this is a texture error. Can it be fixed?0t54n3st0tah.png
    in4c3av1bw1n.png

    This is known, I do not have an ETA for a fix.
  • barrydancerbarrydancer ✭✭✭✭
    Also the text on the starboard outboard and port inboard sides of the nacelles is reversed.

    dcels2qyynab.png
  • Many of the ships have the reversed text on one of the nacelles. I figured it was a bug in the engine.

    But on my iPad Pro 11, the ship looks like this, which makes me sad.
    rlhgjd3op7f9.jpeg
  • /SSR/ AHSOG/SSR/ AHSOG ✭✭✭
    And the underside Shuttlebay or whatever that it is opposite the Deflector is lit Red, should be blue, or dark.
  • /SSR/ AHSOG/SSR/ AHSOG ✭✭✭
    nfe6boznooef.png
    s5rl6aqil1p2.png
Sign In or Register to comment.