Bug: Spotify stops playing when starting STT in iOS

As the title says. Stop touching my music.

It's not just Spotify that STT will stop, either.

Comments

  • <TGE> Clifford<TGE> Clifford ✭✭✭✭✭
    Just so you know, this isn’t new. It’s been happening for more than a year now.

    Pandora, Podcasts, the Music app the phone comes with, anything. It’ll all pause when you open the app.
  • Grant77Grant77 ✭✭✭✭
    Darxide wrote: »
    As the title says. Stop touching my music.

    It's not just Spotify that STT will stop, either.

    It doesn't do that on my Moto 4G, so your device may be the problem.
  • Black PebbleBlack Pebble ✭✭✭✭✭
    edited March 2018
    This is a bug that unfortunately we haven't been able to fix. We have looked into this multiple times, but we haven't been able to identify the cause or come to a solution.

    The only workaround is:
    • Finish loading the game.
    • Switch back to the home screen.
    • Load up Spotify (or preferred audio app).
    • Switch back to the game.
    Hosun Lee
    Civilian, Brand and Marketing
    Ex-Disruptor Beam
  • <TGE> Clifford<TGE> Clifford ✭✭✭✭✭
    This is a bug that unfortunately we haven't been able to fix. We have looked into this multiple times, but we haven't been able to identify the cause or come to a solution.

    The only workaround is:
    • Finish loading the game.
    • Switch back to the home screen.
    • Load up Spotify (or preferred audio app).
    • Switch back to the game.

    Also, if your version iOS is recent, you can swipe up from the bottom of the screen, which will pull up the control center, and hit the play button located there.

    That’s what I do, usually.
  • Dirk GundersonDirk Gunderson ✭✭✭✭✭
    This is a bug that unfortunately we haven't been able to fix. We have looked into this multiple times, but we haven't been able to identify the cause or come to a solution.

    The only workaround is:
    • Finish loading the game.
    • Switch back to the home screen.
    • Load up Spotify (or preferred audio app).
    • Switch back to the game.

    Also, if your version iOS is recent, you can swipe up from the bottom of the screen, which will pull up the control center, and hit the play button located there.

    That’s what I do, usually.

    Same here. An annoyance to be sure, though only a minor one.
  • <TGE> Darxide<TGE> Darxide ✭✭✭
    edited March 2018
    This is a bug that unfortunately we haven't been able to fix. We have looked into this multiple times, but we haven't been able to identify the cause or come to a solution.

    The only workaround is:
    • Finish loading the game.
    • Switch back to the home screen.
    • Load up Spotify (or preferred audio app).
    • Switch back to the game.

    Weird. Well, just know that this isn't specific to STT. I've found another app or two that do the same thing.

    Sorry for not mentioning that I'm on iOS, not that it seems to make a difference.
    Also, if your version iOS is recent, you can swipe up from the bottom of the screen, which will pull up the control center, and hit the play button located there.

    That’s what I do, usually.

    This is also what I do.
  • <TGE> Clifford<TGE> Clifford ✭✭✭✭✭
    Darxide wrote: »
    This is a bug that unfortunately we haven't been able to fix. We have looked into this multiple times, but we haven't been able to identify the cause or come to a solution.

    The only workaround is:
    • Finish loading the game.
    • Switch back to the home screen.
    • Load up Spotify (or preferred audio app).
    • Switch back to the game.

    Weird. Well, just know that this isn't specific to STT. I've found another app or two that do the same thing.

    Sorry for not mentioning that I'm on iOS, not that it seems to make a difference.
    Also, if your version iOS is recent, you can swipe up from the bottom of the screen, which will pull up the control center, and hit the play button located there.

    That’s what I do, usually.

    This is also what I do.

    I usually find this bug on games that come with their own background music. Even after you turn the background music off, it defaults to pausing outside sound.
  • <TGE> Darxide<TGE> Darxide ✭✭✭
    edited March 2018
    I usually find this bug on games that come with their own background music. Even after you turn the background music off, it defaults to pausing outside sound.

    The thing is that it's not all games. And it's not always games. Some non-game apps that I have do this and they don't even play music or video or anything. And some games that do have background music and stuff won't touch Spotify or any other music playing. I suspect that it's less of a bug and more of an iOS "feature" that DB isn't shutting down when the game initializes. Some API call that needs an extra parameter to tell iOS to not stop the background music or something. It's definitely something during initialization since I can start my music back up and the game won't shut down my music again until I see the loading screen again.

    Some games I have are also smart about it. Duels of the Planeswalkers, for instance, will only stop your music if you have the game sound on. If you have the game muted through its own options then it won't touch your music. So it's something that's easily controlled by the developers of the apps. I guess DB is just overlooking the particulars of how to do it. I don't know. I don't develop for mobile. I stick to the good old (and somewhat going out of style) desktop applications.
Sign In or Register to comment.